Add-on Author M0CYP

Add-on Written By Andy - M0CYP перевод на русский язык Роберт Тоболь RZ3AIF 73!

This add-on is distributed as freeware

E-Mail apritch@lineone.net

Website UI-View Web Resource

Copyright 1999-2004


Install

Установка программы

Относится к вурсии UI-View32 V2.03 и выше

Закройте программу UI-View32 и скопируйте все файлы, кроме tabctl32.ocx в директорию \ui-view32. Файл tabctl32.ocx необходимо скопировать в директорию \windows\system или \winnt\system . Но только в том случае, если его там нет.

В программе UI-View32 –меню > Setup -> Excluded/Include List уберите галочку enable exclusions. Все установки будет осуществлять UI-Filter.

Запустите UI-View32, после чего опция UI-Filter появится в File menu основной программы.


Setup Screen

<head<

Синтаксис VB6 Like

Если в полях номер 4-8 ничего не забито, то программа не выполняет никаких исключений.

Если вы введете в поле букву со звездочкой после нее ( G*) то программа будет выделять все позывные, начинающиеся с буквы G.

Первичные фильтры (исключая символы) могут использоваться с синтаксисом VB6 like. Такой синтаксис позволяет задать более сложные условия фильтрации. Например мы можем видеть все станции с минусом и цифрой в конце позывного. Следует в поле Callsign поставить *-# .

Для выделения только MB7Ux станций (где х – любая буква) в поле необходимо ввести

MB7U[A-Z] or MB7U?

Для выделения только MB7Ux станций (где х – любая буква от Q до Z) в поле необходимо ввести

MB7U[!Q-Z]

Вне стандартного синтаксиса VB6 like можно написать следующее выражение

!*_OUTLK

Программа будет выделять все позывные в которых будет в конце присутствовать слово _OUTLK.